summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Aizatsky <aizatsky@chromium.org>2017-01-12 01:19:34 +0000
committerMike Aizatsky <aizatsky@chromium.org>2017-01-12 01:19:34 +0000
commit64d6b142a6d5ccbc3eab9b61fdba1184457e740d (patch)
treecac9b817ccfe996b6f26a7a6bf6a00566ae1ccc0 /lib/CMakeLists.txt
parent9ed4828f5145d7d80622ce923423ac3eda4aae41 (diff)
[sancov] moving sancov rt to sancov/ directory
Subscribers: kubabrecka, mgorny Differential Revision: https://reviews.llvm.org/D28541 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@291734 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 4ab1e933a..461579068 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -36,6 +36,10 @@ function(compiler_rt_build_sanitizer sanitizer)
endif()
endfunction()
+if(COMPILER_RT_HAS_SANITIZER_COMMON)
+ add_subdirectory(sancov)
+endif()
+
if(COMPILER_RT_BUILD_SANITIZERS)
compiler_rt_build_runtime(interception)