summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-19 07:49:16 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-19 07:49:16 +0000
commit2d8d713ce3af9c349149003407c240aa5b1b5b3d (patch)
tree07e51d1f6b21215d1bbd2c0f3dff2e2a9e3f812f /lib/CMakeLists.txt
parent4819e32d7d9862dec08ed171765713b3cb40fdbf (diff)
[CMake] Rudimentary support for standalone CompilerRT build system.
This change allows to build compiler-rt libraries separately from LLVM/Clang (path to LLVM build directory should be specified at configure time). Running tests is not yet supported. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201647 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 14fda1fe4..1c189c2bc 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -4,7 +4,7 @@
include(AddCompilerRT)
include(SanitizerUtils)
# Don't build sanitizers in the bootstrap build.
-if(LLVM_USE_SANITIZER STREQUAL "")
+if(NOT LLVM_USE_SANITIZER)
# AddressSanitizer is supported on Linux and Mac OS X.
# 32-bit Windows support is experimental.
if(CMAKE_SYSTEM_NAME MATCHES "Darwin|Linux")