summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Ricci <francisjricci@gmail.com>2017-06-27 15:22:56 +0000
committerFrancis Ricci <francisjricci@gmail.com>2017-06-27 15:22:56 +0000
commit1c6a7b07545f0c9ce68e8b226f5397694ce48af7 (patch)
tree6766a3c8e10893bfeac8997e810c4e1af93131ec /lib/CMakeLists.txt
parentaa207c1685fec72a06a8a51b0518ed9ad87b0c03 (diff)
Only test sanitizers that are built when COMPILER_RT_SANITIZERS_TO_BUILD is used
Summary: This allows check-all to be used when only a subset of the sanitizers are built. Reviewers: beanz, compnerd Subscribers: llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D34644 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@306415 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 4ab1e933a..7000efb6b 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -28,7 +28,6 @@ function(compiler_rt_build_runtime runtime)
endfunction()
function(compiler_rt_build_sanitizer sanitizer)
- string(TOUPPER ${sanitizer} sanitizer_uppercase)
string(TOLOWER ${sanitizer} sanitizer_lowercase)
list(FIND COMPILER_RT_SANITIZERS_TO_BUILD ${sanitizer_lowercase} result)
if(NOT ${result} EQUAL -1)