summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2012-06-22 21:09:10 +0000
committerChandler Carruth <chandlerc@gmail.com>2012-06-22 21:09:10 +0000
commit0c87068785c951351814b8e7a7d0df29272397b6 (patch)
treed81e6765ee11fe4708b5f66bee6bb96c5bb65c2d /lib/CMakeLists.txt
parent2e82a8bf4cbe8b891f64a0081f64447af9e4ac06 (diff)
Reorder these things for clarity, and add -std=c99 to the compile flags.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@159032 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 7957e4308..68b8cac7c 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -1,3 +1,10 @@
+# First, add the subdirectories which contain feature-based runtime libraries.
+add_subdirectory(sanitizer_common)
+add_subdirectory(asan)
+
+# FIXME: Add support for the profile library.
+
+
# The top-level lib directory contains a large amount of C code which provides
# generic implementations of the core runtime library along with optimized
# architecture-specific code in various subdirectories.
@@ -142,7 +149,7 @@ if(CAN_TARGET_X86_64)
x86_64/floatundixf.S
${GENERIC_SOURCES}
)
- set_target_properties(clang_rt.x86_64 PROPERTIES COMPILE_FLAGS "${TARGET_X86_64_CFLAGS}")
+ set_target_properties(clang_rt.x86_64 PROPERTIES COMPILE_FLAGS "-std=c99 ${TARGET_X86_64_CFLAGS}")
endif()
if(CAN_TARGET_I386)
add_library(clang_rt.i386 STATIC
@@ -162,12 +169,5 @@ if(CAN_TARGET_I386)
i386/umoddi3.S
${GENERIC_SOURCES}
)
- set_target_properties(clang_rt.i386 PROPERTIES COMPILE_FLAGS "${TARGET_I386_CFLAGS}")
+ set_target_properties(clang_rt.i386 PROPERTIES COMPILE_FLAGS "-std=c99 ${TARGET_I386_CFLAGS}")
endif()
-
-# Also support building feature-based runtime libraries in their various
-# subdircetories.
-add_subdirectory(sanitizer_common)
-add_subdirectory(asan)
-
-# FIXME: Add support for the profile library.