summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Bruening <bruening@google.com>2016-07-09 04:13:25 +0000
committerDerek Bruening <bruening@google.com>2016-07-09 04:13:25 +0000
commitbcdfb408444c657422499a2274eb377879588e89 (patch)
treeaedcaccf6e02afc9348c1680cddf2df18aecc29e /include/CMakeLists.txt
parent87110b4eb106dc2ccaaa74647293fe6e05cabb96 (diff)
[esan] Add __esan_report for mid-run data
Summary: Adds a new public interface routine __esan_report() which can be used to request profiling results prior to abnormal termination (e.g., for a server process killed by its parent where the normal exit does not allow for normal result reporting). Implements this for the working-set tool. The cache frag tool is left unimplemented as it requires missing iteration capabilities. Adds a new test. Reviewers: aizatsky Subscribers: vitalybuka, zhaoqin, kcc, eugenis, llvm-commits, kubabrecka Differential Revision: http://reviews.llvm.org/D22098 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@274964 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index ad1437ed1..0139b0601 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -4,6 +4,7 @@ set(SANITIZER_HEADERS
sanitizer/common_interface_defs.h
sanitizer/coverage_interface.h
sanitizer/dfsan_interface.h
+ sanitizer/esan_interface.h
sanitizer/linux_syscall_hooks.h
sanitizer/lsan_interface.h
sanitizer/msan_interface.h