summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitry Vyukov <dvyukov@google.com>2017-03-26 15:27:04 +0000
committerDmitry Vyukov <dvyukov@google.com>2017-03-26 15:27:04 +0000
commit96ccf181c8c1bf446bae8fc738b3dc8da5a65cfe (patch)
treef748f9f972ba30415914b0bd3863526a3578b590 /include/CMakeLists.txt
parent7218fa55e35c76ef0947cb0e9261696dc11e168d (diff)
tsan: add new mutex annotations
There are several problems with the current annotations (AnnotateRWLockCreate and friends): - they don't fully support deadlock detection (we need a hook _before_ mutex lock) - they don't support insertion of random artificial delays to perturb execution (again we need a hook _before_ mutex lock) - they don't support setting extended mutex attributes like read/write reentrancy (only "linker init" was bolted on) - they don't support setting mutex attributes if a mutex don't have a "constructor" (e.g. static, Java, Go mutexes) - they don't ignore synchronization inside of lock/unlock operations which leads to slowdown and false negatives The new annotations solve of the above problems. See tsan_interface.h for the interface specification and comments. Reviewed in https://reviews.llvm.org/D31093 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@298809 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 1f8b481e7..6104aded2 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -8,6 +8,7 @@ set(SANITIZER_HEADERS
sanitizer/linux_syscall_hooks.h
sanitizer/lsan_interface.h
sanitizer/msan_interface.h
+ sanitizer/tsan_interface.h
sanitizer/tsan_interface_atomic.h)
set(XRAY_HEADERS