summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorDean Michael Berris <dberris@google.com>2017-03-29 05:19:24 +0000
committerDean Michael Berris <dberris@google.com>2017-03-29 05:19:24 +0000
commit8b987788165d15b1c5980751392c179defa86ab7 (patch)
tree20186b197cbc95362dade50c1e38c2d17af9efc4 /include/CMakeLists.txt
parent260f2c513bdffce646c53abc285fb1343afc9719 (diff)
[XRay][compiler-rt] Add an end-to-end test for FDR Logging
Summary: This change exercises the end-to-end functionality defined in the FDR logging implementation. We also prepare for being able to run traces generated by the FDR logging implementation from being analysed with the llvm-xray command that comes with the LLVM distribution. This also unblocks D31385, D31384, and D31345. Reviewers: kpw, pelikan Subscribers: llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D31452 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@298977 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 6104aded2..3d6c96be9 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -12,7 +12,8 @@ set(SANITIZER_HEADERS
sanitizer/tsan_interface_atomic.h)
set(XRAY_HEADERS
- xray/xray_interface.h)
+ xray/xray_interface.h
+ xray/xray_log_interface.h)
set(COMPILER_RT_HEADERS
${SANITIZER_HEADERS}