summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2016-07-20 21:37:38 +0000
committerHans Wennborg <hans@hanshq.net>2016-07-20 21:37:38 +0000
commit3261cf3c2813d79b53997498781503eaad6dd2f7 (patch)
treed0d6bb1eadbdbf005a12965e6e571985826513de /include/CMakeLists.txt
parent3aa2882179d440943c3b3750b1600039785bf7c6 (diff)
Revert r276117 "[XRay] Basic initialization and flag definition for XRay runtime"
and also the follow-up "[xray] Only build xray on Linux for now" Two build errors were reported on the llvm-commits list: [ 88%] Building CXX object lib/xray/CMakeFiles/clang_rt.xray-x86_64.dir/xray_flags.cc.o /mnt/b/sanitizer-buildbot1/sanitizer-x86_64-linux/build/llvm/projects/compiler-rt/lib/xray/xray_init.cc:23:10: fatal error: 'llvm/Support/ELF.h' file not found #include "llvm/Support/ELF.h" ^ and In file included from /w/src/llvm.org/projects/compiler-rt/lib/xray/xray_interface.cc:16: /w/src/llvm.org/projects/compiler-rt/lib/xray/xray_interface_internal.h:36:8: error: no type named 'size_t' in namespace 'std' std::size_t Entries; ~~~~~^ git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276186 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt13
1 files changed, 1 insertions, 12 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 1f8b481e7..5161d4ee9 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -10,18 +10,11 @@ set(SANITIZER_HEADERS
sanitizer/msan_interface.h
sanitizer/tsan_interface_atomic.h)
-set(XRAY_HEADERS
- xray/xray_interface.h)
-
-set(COMPILER_RT_HEADERS
- ${SANITIZER_HEADERS}
- ${XRAY_HEADERS})
-
set(output_dir ${COMPILER_RT_OUTPUT_DIR}/include)
# Copy compiler-rt headers to the build tree.
set(out_files)
-foreach( f ${COMPILER_RT_HEADERS} )
+foreach( f ${SANITIZER_HEADERS} )
set( src ${CMAKE_CURRENT_SOURCE_DIR}/${f} )
set( dst ${output_dir}/${f} )
add_custom_command(OUTPUT ${dst}
@@ -39,7 +32,3 @@ set_target_properties(compiler-rt-headers PROPERTIES FOLDER "Compiler-RT Misc")
install(FILES ${SANITIZER_HEADERS}
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
DESTINATION ${COMPILER_RT_INSTALL_PATH}/include/sanitizer)
-# Install xray headers.
-install(FILES ${XRAY_HEADERS}
- PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
- DESTINATION ${COMPILER_RT_INSTALL_PATH}/include/xray)