summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-11-18 10:57:36 +0000
committerAlexey Samsonov <samsonov@google.com>2013-11-18 10:57:36 +0000
commit0fbf056b4dbe12f63cefe7488c76d08cb8b26788 (patch)
treec2180581fcb7c420e38c8e779eb3d7d936cdd041 /include/CMakeLists.txt
parent8b0c8a8b6fd2817b0697c255297ca9d48076fcbf (diff)
CMake: make sure compiler-rt headers are copied to build tree if 'compilrer-rt' target is built
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@195002 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 67e1327a3..d8a73872b 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -34,6 +34,7 @@ foreach( f ${SANITIZER_HEADERS} )
endforeach( f )
add_custom_target(compiler-rt-headers ALL DEPENDS ${out_files})
+add_dependencies(compiler-rt compiler-rt-headers)
# Install sanitizer headers.
install(FILES ${SANITIZER_HEADERS}