summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-24 11:32:49 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-24 11:32:49 +0000
commitfbf8ff3d4c76bc001e77778cc03c441255e3596e (patch)
tree7b54b24b2ef5895ec8a6f4e6bf9f44519225d405 /CMakeLists.txt
parent72e55c5d2674790e94dc66696730963916f4dba1 (diff)
[CMake] Better support for COMPILER_RT_ENABLE_WERROR. Make sure compiler-rt libraries are build by 'make all' command
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@202023 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6deba556a..3af1f6aff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ else()
endif()
# Top level target used to build all compiler-rt libraries.
-add_custom_target(compiler-rt)
+add_custom_target(compiler-rt ALL)
if (NOT COMPILER_RT_STANDALONE_BUILD)
# Compute the Clang version from the LLVM version.
@@ -219,7 +219,8 @@ pythonize_bool(COMPILER_RT_DEBUG)
include(config-ix)
if(COMPILER_RT_ENABLE_WERROR)
- add_definitions(-Werror)
+ add_definitions_if(COMPILER_RT_HAS_WERROR_FLAG -Werror)
+ add_definitions_if(COMPILER_RT_HAS_WX_FLAG /WX)
endif()
# Provide some common commmandline flags for Sanitizer runtimes.