summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-04 13:24:13 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-04 13:24:13 +0000
commite7cc26b7c5590645a485cef850f3d6d3cb47e7ba (patch)
tree8e11bef79168e5f4546eda980869b04d8f595e4e /CMakeLists.txt
parent197c2be6793e3325c0afd48c9cbcde05e9b147e5 (diff)
[CMake] Fixup for r200753
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@200761 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0826df0e1..68f7d21c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,7 +164,7 @@ if (NOT MSVC)
endif()
endif()
# Build sanitizer runtimes with -fno-function-sections.
-check_cxx_compiler_flag(-Werror -fno-function-sections SUPPORTS_FNO_FUNCTION_SECTIONS_FLAG)
+check_cxx_compiler_flag("-Werror -fno-function-sections" SUPPORTS_FNO_FUNCTION_SECTIONS_FLAG)
if(SUPPORTS_FNO_FUNCTION_SECTIONS_FLAG)
list(APPEND SANITIZER_COMMON_CFLAGS -fno-function-sections)
endif()