summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-11-17 09:41:47 +0000
committerAlexey Samsonov <samsonov@google.com>2013-11-17 09:41:47 +0000
commitc85d6274d127d988539ed6a35242d3f82c4eb5bf (patch)
tree3175021cd3910082e7fc35cba71d7f20374dc6e9 /CMakeLists.txt
parentf7e060d01b766e1626a959bfecd383cf0ac76d66 (diff)
[DFSan] Don't include public headers in dfsan runtime code
Summary: Definitions we use in public sanitizer headers may slightly conflict with the ones we use in private sanitizer runtimes. Moreover, we generally forbid to include any system headers (like <stdint.h>) in sanitizer runtime headers. This leads to inevitable duplication of selected interface function declarations, but we decided to live with it. Reviewers: pcc Reviewed By: pcc CC: kcc, llvm-commits Differential Revision: http://llvm-reviews.chandlerc.com/D2179 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@194955 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cd09be91..4c0476b6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -212,8 +212,6 @@ endif()
filter_available_targets(SANITIZER_COMMON_SUPPORTED_ARCH
x86_64 i386 powerpc64)
-# Add the public header's directory to the includes for all of compiler-rt.
-include_directories(include)
add_subdirectory(include)
set(SANITIZER_COMMON_LIT_TEST_DEPS