summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2014-08-12 20:03:33 +0000
committerHans Wennborg <hans@hanshq.net>2014-08-12 20:03:33 +0000
commitb8778f5427609e9f75a58f1c56f7533851ca0292 (patch)
tree1d2f65d3d5f06239533d499d221de4c72618ba0e /CMakeLists.txt
parent92507a987fc16b350e4f83fa7539d32d9d5e7a46 (diff)
Fix the CMake build when setting MACOSX_DEPLOYMENT_TARGET
If we don't reset CMAKE_OSX_DEPLOYMENT_TARGET, it will end up in CFLAGS together with the -mmacosx-version-min that we set, and the compiler errors about the conflict. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@215468 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8f8cc397..f0d53ffad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -294,6 +294,7 @@ if(APPLE)
else()
set(SANITIZER_MIN_OSX_VERSION 10.6)
endif()
+ set(CMAKE_OSX_DEPLOYMENT_TARGET "") # We're setting the flag manually below.
set(DARWIN_osx_CFLAGS -mmacosx-version-min=${SANITIZER_MIN_OSX_VERSION})
set(DARWIN_iossim_CFLAGS
-mios-simulator-version-min=7.0 -isysroot ${IOSSIM_SDK_DIR})