summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimur Iskhodzhanov <timurrrr@google.com>2014-05-13 14:25:49 +0000
committerTimur Iskhodzhanov <timurrrr@google.com>2014-05-13 14:25:49 +0000
commitb58e7f412543c2641e2bc8d087fe6836f426cb92 (patch)
tree5446ff359e2e59264865622617f9bd0d1d6fdafc /CMakeLists.txt
parent8570be3fce1a4a8216265afe0ad9e79c2f07bdb6 (diff)
Enable sanitizer tests (check-sanitizer, check-asan) on Windows
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@208701 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1287d9e4b..5ef149499 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -218,10 +218,10 @@ else()
endif()
endif()
-# We only support running instrumented tests when we're not cross compiling
-# and target a unix-like system. We can run tests on Android even when we are
-# cross-compiling.
-if(("${CMAKE_HOST_SYSTEM}" STREQUAL "${CMAKE_SYSTEM}" AND UNIX) OR ANDROID)
+# We support running instrumented tests when we're not cross compiling
+# and target a UNIX-like system or Windows.
+# We can run tests on Android even when we are cross-compiling.
+if(("${CMAKE_HOST_SYSTEM}" STREQUAL "${CMAKE_SYSTEM}" AND (UNIX OR MSVC)) OR ANDROID)
option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" ON)
else()
option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" OFF)