summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-03-06 12:25:02 +0000
committerAlexey Samsonov <samsonov@google.com>2014-03-06 12:25:02 +0000
commitb5079421e7a086b207df4d655e006145f5560ead (patch)
tree7c326babaed907330d47337e3fb4ffdf26950d23 /CMakeLists.txt
parentc847a57ef2a49346bba535d54252b08277cfdae6 (diff)
[CMake] Build compiler-rt libraries with -Wall
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@203113 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a0819d51a..830a5f0e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -235,6 +235,7 @@ pythonize_bool(COMPILER_RT_DEBUG)
#================================
include(config-ix)
+add_definitions_if(COMPILER_RT_HAS_WALL_FLAG -Wall)
if(COMPILER_RT_ENABLE_WERROR)
add_definitions_if(COMPILER_RT_HAS_WERROR_FLAG -Werror)
add_definitions_if(COMPILER_RT_HAS_WX_FLAG /WX)