summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorShantonu Sen <ssen@apple.com>2009-09-22 00:49:12 +0000
committerShantonu Sen <ssen@apple.com>2009-09-22 00:49:12 +0000
commitb4c3b6f8a2d3481bac6b0e9b4240fa0c99412d10 (patch)
treeecfc1c923f3e6991c75264d5a8e9edd2d394e492 /CMakeLists.txt
parent92a6cf5b64bb661c8b67825a4a5583eb01807633 (diff)
1) Remove cmake-specific #define usage from the exported
Block.h/Block_private.h headers, since clients won't know what to set. These are moved into runtime.c as appropriate 2) Use cmake checks for CAS builtins, instead of guessing based on GCC #defines (which aren't set by clang and llvm-gcc anyway) 3) "#pragma mark" isn't supported by FSF gcc, so "#if 0" it out. It should still show up in IDEs that support it 4) Fix some compiler warnings. GCC 4.3.3 seems super strict about %p. function pointers can't be cast to void * either. 5) Avoid a warning for apple_versioning.c that "ISO C does not allow empty files" git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@82504 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 165422eba..064fde0af 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,13 +26,6 @@ INCLUDE_DIRECTORIES(
${CMAKE_CURRENT_BINARY_DIR}
)
-install(DIRECTORY include
- DESTINATION .
- PATTERN ".svn" EXCLUDE
- PATTERN "*.cmake" EXCLUDE
- PATTERN "*.in" EXCLUDE
- )
-
SET( Achitectures
i386 x86_64 ppc arm
)