summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Northover <tnorthover@apple.com>2017-06-05 15:10:04 +0000
committerTim Northover <tnorthover@apple.com>2017-06-05 15:10:04 +0000
commitb058fd625f568029ac4b2585fe2e507b6a77b653 (patch)
tree4a50b5cb17fe4b282e32927af265921961609fb1 /CMakeLists.txt
parent9c790e8abc177dee14e192c982c911f37b9653e7 (diff)
CMake: don't try to use lld if we're not building it.
Monorepo version! git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@304716 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b522c340d..51769088a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,7 +255,7 @@ if(EXISTS ${COMPILER_RT_LLD_PATH}/ AND LLVM_TOOL_LLD_BUILD)
set(COMPILER_RT_HAS_LLD TRUE)
else()
set(COMPILER_RT_LLD_PATH ${LLVM_MAIN_SRC_DIR}/../lld)
- if(EXISTS ${COMPILER_RT_LLD_PATH}/)
+ if(EXISTS ${COMPILER_RT_LLD_PATH}/ AND LLVM_TOOL_LLD_BUILD)
set(COMPILER_RT_HAS_LLD TRUE)
else()
set(COMPILER_RT_HAS_LLD FALSE)