summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Ricci <francisjricci@gmail.com>2017-09-19 17:54:11 +0000
committerFrancis Ricci <francisjricci@gmail.com>2017-09-19 17:54:11 +0000
commitaf5d32eeb88de110fcb0aa1c5eaa77833d421ba9 (patch)
treef000c0508f2eb8116cd0a291be0169a3d524856a /CMakeLists.txt
parent4035097abb6703beaaa9fbbf9bdbd80a1ab522c1 (diff)
Ensure that armhf builtins library is created when using an hf abi
Reviewers: beanz, compnerd Reviewed By: compnerd Subscribers: aemerson, mgorny, kristof.beyls, llvm-commits Differential Revision: https://reviews.llvm.org/D38045 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@313650 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd408d7e6..a3df7cc0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,11 @@ if (COMPILER_RT_STANDALONE_BUILD)
endif()
construct_compiler_rt_default_triple()
+if ("${COMPILER_RT_DEFAULT_TARGET_ABI}" MATCHES "hf$")
+ if (${COMPILER_RT_DEFAULT_TARGET_ARCH} MATCHES "^arm")
+ set(COMPILER_RT_DEFAULT_TARGET_ARCH "armhf")
+ endif()
+endif()
if ("${COMPILER_RT_DEFAULT_TARGET_ABI}" STREQUAL "androideabi")
set(ANDROID 1)
endif()