summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2018-05-17 23:50:35 +0000
committerPetr Hosek <phosek@chromium.org>2018-05-17 23:50:35 +0000
commitabcaa923f16eb45c8a9a450d783c7bc01c36b267 (patch)
tree5c0a6966c47000b8a7cf2487d52aa650e2c966f0 /CMakeLists.txt
parent313baf68df116ba3fff8c94ad7d339a78ba67d46 (diff)
[CMake] Reland "Make simple source used for CMake checks a C file"
The source being compiled is plain C, but using .cc extension forces it to be compiled as C++ which requires a working C++ compiler including C++ library which may not be the case when we're building compiler-rt together with libcxx as part of runtimes build. Differential Revision: https://reviews.llvm.org/D47031 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@332679 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57045c206..84a7dcd81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -145,6 +145,7 @@ if (SANITIZER_CXX_ABI STREQUAL "default")
set(SANITIZER_CXX_ABI_SYSTEM 1)
else()
set(SANITIZER_CXX_ABI_LIBNAME "libstdc++")
+ set(SANITIZER_CXX_ABI_SYSTEM 1)
endif()
else()
set(SANITIZER_CXX_ABI_LIBNAME "${SANITIZER_CXX_ABI}")