summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Potapenko <glider@google.com>2013-11-19 14:58:42 +0000
committerAlexander Potapenko <glider@google.com>2013-11-19 14:58:42 +0000
commita79fd98374011b1621454e34d956d4bbfe54da79 (patch)
tree63706aa52e20a36760dba880717dbbc58bbf976b /CMakeLists.txt
parent7bde62e9efd296e6a01e641fde679a772ee72201 (diff)
[ASan] Use -isysroot instead of -Wl,-syslibroot to link the ASan iossim runtime
(-Wl,-syslibroot was accidentally overridden by -isysroot from Clang on OSX 10.9) -isysroot is a Clang/LLVM-GCC-specific option, but hosting libsanitizer for LLVM with GCC on Darwin shouldn't work anyway, because of the missing blocks support. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@195132 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c0476b6b..a4424086c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -204,7 +204,7 @@ if(APPLE)
set(DARWIN_iossim_LINKFLAGS
-Wl,-ios_simulator_version_min,7.0.0
-mios-simulator-version-min=7.0
- -Wl,-syslibroot,${IOSSIM_SDK_DIR})
+ -isysroot ${IOSSIM_SDK_DIR})
endif()
# Architectures supported by Sanitizer runtimes. Specific sanitizers may