summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Hines <srhines@google.com>2018-07-11 00:50:03 +0000
committerStephen Hines <srhines@google.com>2018-07-11 00:50:03 +0000
commita23f2b1f37752905e78ef7a8480da2d1b45b64dc (patch)
treec971d115f4e86f0754f51a6ab9f1d447c1409bb3 /CMakeLists.txt
parenta996ac965d6a1f03dd37109ee54a37894be24365 (diff)
Add libcxxabi option back for sanitizer use.
Summary: A prior refactoring accidentally dropped the case for using libc++abi as the out-of-tree C++ runtime library for sanitizers. This patch restores that functionality, which is used by Android, which can't depend on the full libc++ for these libraries. Reviewers: phosek, EricWF Reviewed By: phosek Subscribers: meikeb, kongyi, chh, mgorny, delcypher, llvm-commits, #sanitizers, pirama Differential Revision: https://reviews.llvm.org/D49157 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@336749 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ece416f4..be4066f22 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -353,6 +353,8 @@ if (SANITIZER_CXX_ABI_LIBNAME STREQUAL "libc++")
else()
append_list_if(COMPILER_RT_HAS_LIBCXX c++ SANITIZER_CXX_ABI_LIBRARY)
endif()
+elseif (SANITIZER_CXX_ABI_LIBNAME STREQUAL "libcxxabi")
+ list(APPEND SANITIZER_CXX_ABI_LIBRARY "c++abi")
elseif (SANITIZER_CXX_ABI_LIBNAME STREQUAL "libstdc++")
append_list_if(COMPILER_RT_HAS_LIBSTDCXX stdc++ SANITIZER_CXX_ABI_LIBRARY)
endif()