summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Bogner <mail@justinbogner.com>2014-02-04 10:40:46 +0000
committerJustin Bogner <mail@justinbogner.com>2014-02-04 10:40:46 +0000
commit9e18dd17aa127c2ffc7b14d113ba3becc9a5284f (patch)
treeb52659d458c5812c487267d3cf0146e12153f4b2 /CMakeLists.txt
parent15f46f617c0b1fb6ffbf312c30448413ff5046e0 (diff)
CMake: Enable -Werror for the -fno-function-sections check
If the -fno-function-sections flag isn't recognized, the compiler emits a warning. This isn't enough to cause the check to fail, so we enable -Werror as well. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@200753 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbae1ccc1..0826df0e1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,7 +164,7 @@ if (NOT MSVC)
endif()
endif()
# Build sanitizer runtimes with -fno-function-sections.
-check_cxx_compiler_flag(-fno-function-sections SUPPORTS_FNO_FUNCTION_SECTIONS_FLAG)
+check_cxx_compiler_flag(-Werror -fno-function-sections SUPPORTS_FNO_FUNCTION_SECTIONS_FLAG)
if(SUPPORTS_FNO_FUNCTION_SECTIONS_FLAG)
list(APPEND SANITIZER_COMMON_CFLAGS -fno-function-sections)
endif()