summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-09 18:41:02 +0000
committerEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-09 18:41:02 +0000
commit8bf1e094893cb24796137b47ee0d46d18d299996 (patch)
tree57669837db32d106ba744be339a354b8055fcfe4 /CMakeLists.txt
parent33c134702e274fdbcb1672771a137efb82b498b2 (diff)
Refactor to remove un-named struct gnu extension usage. Now ISO C89 and C99 compliant. Comment trailing endifs
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@78537 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a1bda82f..4ecba0770 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# See docs/CMake.html for instructions about how to build Compiler-RT with CMake.
-PROJECT( CompilerRT )
+PROJECT( CompilerRT C )
CMAKE_MINIMUM_REQUIRED( VERSION 2.6 )
set(PACKAGE_NAME compiler-rt)
@@ -29,11 +29,19 @@ install(DIRECTORY include
PATTERN "*.in" EXCLUDE
)
+SET( Achitectures
+ i386 ppc x86_64
+ )
+
+SET( Configurations
+ Debug Release Profile
+ )
+
# BlocksRuntime - some random cruft that got thrown in at the last minute, ignoring for now.
# ADD_SUBDIRECTORY( BlocksRuntime )
ADD_SUBDIRECTORY( lib )
# Tests are being ignored for until the very basics are working.
-# INCLUDE( MacroAddCheckTest )
-# ADD_SUBDIRECTORY( test )
+#INCLUDE( MacroAddCheckTest )
+#ADD_SUBDIRECTORY( test )