summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@codeaurora.org>2014-05-14 00:36:15 +0000
committerGreg Fitzgerald <gregf@codeaurora.org>2014-05-14 00:36:15 +0000
commit783e9704cda4b9e3f8176cf33bfc61025e405f72 (patch)
tree37056ff1fa15715ce8c645b9cc2781691c79f253 /CMakeLists.txt
parent3c1af3e8f5c8043ca041c8fabd7cad9dc9c7cc63 (diff)
Enable CAN_EXECUTE_TESTS if an EMULATOR is provided
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@208745 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ef149499..2d65e3b92 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,7 +221,8 @@ endif()
# We support running instrumented tests when we're not cross compiling
# and target a UNIX-like system or Windows.
# We can run tests on Android even when we are cross-compiling.
-if(("${CMAKE_HOST_SYSTEM}" STREQUAL "${CMAKE_SYSTEM}" AND (UNIX OR MSVC)) OR ANDROID)
+if(("${CMAKE_HOST_SYSTEM}" STREQUAL "${CMAKE_SYSTEM}" AND (UNIX OR MSVC)) OR ANDROID
+ OR COMPILER_RT_EMULATOR)
option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" ON)
else()
option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" OFF)