summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2018-05-09 21:24:06 +0000
committerPetr Hosek <phosek@chromium.org>2018-05-09 21:24:06 +0000
commit6d822c4e3a08225b984f971149746b1b5273dea5 (patch)
tree15fe78d06d3c13d9141557d9b72f446682391e0e /CMakeLists.txt
parente025663e073ae23b2eaeedeac0f341489fc9ad94 (diff)
[CMake] Build shared version of runtimes for Fuchsia
Fuchsia is no longer treated as UNIX which means we need to explicitly enable building of shared versions of runtimes. Differential Revision: https://reviews.llvm.org/D46609 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@331922 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aaf6789d6..57045c206 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -278,6 +278,12 @@ else()
set(SANITIZER_LIMIT_FRAME_SIZE FALSE)
endif()
+if(FUCHSIA OR UNIX)
+ set(SANITIZER_USE_SYMBOLS TRUE)
+else()
+ set(SANITIZER_USE_SYMBOLS FALSE)
+endif()
+
# Build sanitizer runtimes with debug info.
if(MSVC)
# Use /Z7 instead of /Zi for the asan runtime. This avoids the LNK4099