summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2014-03-31 13:50:13 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2014-03-31 13:50:13 +0000
commit61c029ca902cbc9ce1db0bf30cf2f4525dd60a7d (patch)
tree162e0f4127d5917986d40a0e88f6efc2bdf35089 /CMakeLists.txt
parente18b78588ef4aac46204c7b23d076221993edade (diff)
[sanitizer] Test that we can compile C++ code on the target platform.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@205184 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbc32f112..3b295e72d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -172,8 +172,8 @@ endfunction()
# platform. We use the results of these tests to build only the various target
# runtime libraries supported by our current compilers cross-compiling
# abilities.
-set(SIMPLE_SOURCE ${CMAKE_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/simple.c)
-file(WRITE ${SIMPLE_SOURCE} "#include <stdlib.h>\nint main() {}\n")
+set(SIMPLE_SOURCE ${CMAKE_BINARY_DIR}${CMAKE_FILES_DIRECTORY}/simple.cc)
+file(WRITE ${SIMPLE_SOURCE} "#include <stdlib.h>\n#include <limits>\nint main() {}\n")
# test_target_arch(<arch> <target flags...>)
# Sets the target flags for a given architecture and determines if this