summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2017-08-14 20:42:43 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2017-08-14 20:42:43 +0000
commit435b4b3eb8f094a9ccb434b23aa87b1e56055dac (patch)
tree54571b6e29e3f48190be62e9ba08a12887d7c4dd /CMakeLists.txt
parent3caa058f838394a73e896a500784a21915f209ef (diff)
Fix a cmake typo.
Also add "libc++" to list of property values (AFAIK that only affects the cmake gui). git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@310883 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1db04f3a4..e3e5627e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,7 +104,7 @@ pythonize_bool(SANITIZER_CAN_USE_CXXABI)
set(SANITIZER_CXX_ABI "default" CACHE STRING
"Specify C++ ABI library to use.")
-set(CXXABIS none default libcxxabi libstdc++)
+set(CXXABIS none default libcxxabi libstdc++ libc++)
set_property(CACHE SANITIZER_CXX_ABI PROPERTY STRINGS ;${CXXABIS})
if (SANITIZER_CXX_ABI STREQUAL "default")
@@ -117,7 +117,7 @@ if (SANITIZER_CXX_ABI STREQUAL "default")
else()
set(SANITIZER_CXX_ABI_LIBNAME "libstdc++")
endif()
-elseif()
+else()
set(SANITIZER_CXX_ABI_LIBNAME "${SANITIZER_CXX_ABI}")
endif()