summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2014-07-26 04:04:02 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2014-07-26 04:04:02 +0000
commit1f5b48b9fa31ab95c3916a4f81f3a91916efd09c (patch)
tree884b7b14b5752496cf9ef5644188fb923ff637e5 /CMakeLists.txt
parent90b88645985e9d5df5e184d46f0737ebcfe95999 (diff)
builtins: re-enable building assembly sources
Re-apply SVN r213684 which was reverted in SVN r213724 since it broke the build bots. Add a tweak to enable inclusion of the assembly sources in standalone build as well. Original commit message: This patch address the PR20360. The CMake assembler build system ignores the .S assembly files in builtins library build. This patch fixes the issue. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@214013 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f35a09612..78413b003 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@
# Check if compiler-rt is built as a standalone project.
if (CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR)
- project(CompilerRT)
+ project(CompilerRT ASM C CXX)
set(COMPILER_RT_STANDALONE_BUILD TRUE)
else()
set(COMPILER_RT_STANDALONE_BUILD FALSE)