summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2014-10-15 18:23:57 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2014-10-15 18:23:57 +0000
commit1d7819bcce8836dc543e200d6acc1fac8ded0a36 (patch)
treebbd5a4f1841bc267496ade0d39d3497fc34f9719 /CMakeLists.txt
parente7d13c31c0ed41ecd21c1c239622e8f5d5443af2 (diff)
[CMake] Cleanup CMake rules after r219302. NFC.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@219825 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5333db46..777c6fe07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -198,10 +198,6 @@ else()
option(COMPILER_RT_CAN_EXECUTE_TESTS "Can we execute instrumented tests" OFF)
endif()
-# Check if compiler-rt is built with libc++.
-find_flag_in_string("${CMAKE_CXX_FLAGS}" "-stdlib=libc++"
- COMPILER_RT_USES_LIBCXX)
-
option(COMPILER_RT_DEBUG "Build runtimes with full debug info" OFF)
# COMPILER_RT_DEBUG_PYBOOL is used by lit.common.configured.in.
pythonize_bool(COMPILER_RT_DEBUG)
@@ -296,14 +292,10 @@ if(APPLE)
list(APPEND SANITIZER_COMMON_SUPPORTED_DARWIN_OS iossim)
endif()
- if(COMPILER_RT_USES_LIBCXX)
- set(SANITIZER_MIN_OSX_VERSION 10.7)
- else()
- set(SANITIZER_MIN_OSX_VERSION 10.7)
- endif()
+ set(SANITIZER_MIN_OSX_VERSION 10.7)
set(CMAKE_OSX_DEPLOYMENT_TARGET "") # We're setting the flag manually below.
set(DARWIN_osx_CFLAGS -mmacosx-version-min=${SANITIZER_MIN_OSX_VERSION})
- set(DARWIN_iossim_CFLAGS
+ set(DARWIN_iossim_CFLAGS
-mios-simulator-version-min=7.0 -isysroot ${IOSSIM_SDK_DIR})
set(DARWIN_osx_LINKFLAGS)
set(DARWIN_iossim_LINKFLAGS