summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-12 07:26:40 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-12 07:26:40 +0000
commit18cc59386a0184ffe561d594408cc500cb6e0c12 (patch)
tree5e622c159ff50ccbf35e229bd74fe69cedaad85a /CMakeLists.txt
parent12b273c73c221112ea73c1eb703d6019ac37758a (diff)
[Sanitizer] Build sanitizer_common with -Wframe-larger-than=512 flag
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201213 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d41761cfb..8f00eeaeb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -193,6 +193,8 @@ if (SUPPORTS_NO_NON_VIRTUAL_DTOR_FLAG)
endif()
check_cxx_compiler_flag(-Wglobal-constructors SUPPORTS_GLOBAL_CONSTRUCTORS_FLAG)
# Not all sanitizers forbid global constructors.
+check_cxx_compiler_flag("-Werror -Wframe-larger-than=512"
+ SUPPORTS_FRAME_LARGER_THAN_FLAG)
if(APPLE)
# Obtain the iOS Simulator SDK path from xcodebuild.