summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-05 01:47:29 +0000
committerEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-05 01:47:29 +0000
commit0e4ad9c55a8554a220af3dc6b0fc4b0a5d64c025 (patch)
tree4c4ac7f8fbb9afffc22ab04ef63e9dfd5eecc5fc /CMakeLists.txt
parentf361ff15d3a8286e27f8adc8d02c9d3ed79fc8db (diff)
Start porting compiler-rt testsuit to Solaris with new build system. Fix some C++ style comments which are not allowed in ISO C90.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@78143 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 791ed6fbd..3a1bda82f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,12 +10,18 @@ set(PACKAGE_BUGREPORT "llvmbugs@cs.uiuc.edu")
SET( CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/Modules )
+# add definitions
+include(DefineCompilerFlags)
+
# Disallow in-source build
INCLUDE( MacroEnsureOutOfSourceBuild )
MACRO_ENSURE_OUT_OF_SOURCE_BUILD(
"${PROJECT_NAME} requires an out of source build. Please create a separate build directory and run 'cmake /path/to/${PROJECT_NAME} [options]' there."
)
+INCLUDE( ConfigureChecks.cmake )
+CONFIGURE_FILE( config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h )
+
install(DIRECTORY include
DESTINATION .
PATTERN ".svn" EXCLUDE
@@ -25,9 +31,9 @@ install(DIRECTORY include
# BlocksRuntime - some random cruft that got thrown in at the last minute, ignoring for now.
# ADD_SUBDIRECTORY( BlocksRuntime )
+
ADD_SUBDIRECTORY( lib )
+
# Tests are being ignored for until the very basics are working.
+# INCLUDE( MacroAddCheckTest )
# ADD_SUBDIRECTORY( test )
-
-INCLUDE( ConfigureChecks.cmake )
-CONFIGURE_FILE( config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h )