summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-03 01:08:25 +0000
committerEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-03 01:08:25 +0000
commitd904635616ca27a56531375a7d25547c930a4040 (patch)
tree2debf48933b911292580b8ed393f7f19017f78d2 /CMakeLists.txt
parentad9a17686dff730aa89f181b22ab4ec827d40be2 (diff)
Initial import of CMake type build system. Just like the rest of llvm..
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@77933 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..4ef82bef0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,34 @@
+# See docs/CMake.html for instructions about how to build Compiler-RT with CMake.
+
+project(CompilerRT)
+cmake_minimum_required(VERSION 2.6.1)
+
+set(PACKAGE_NAME compiler-rt)
+set(PACKAGE_VERSION 1.0svn)
+set(PACKAGE_STRING "${PACKAGE_NAME} ${PACKAGE_VERSION}")
+set(PACKAGE_BUGREPORT "llvmbugs@cs.uiuc.edu")
+
+if( CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR AND NOT MSVC_IDE )
+ message(FATAL_ERROR "In-source builds are not allowed.
+CMake would overwrite the makefiles distributed with Compiler-RT.
+Please create a directory and run cmake from there, passing the path
+to this source directory as the last argument.
+This process created the file `CMakeCache.txt' and the directory `CMakeFiles'.
+Please delete them.")
+endif()
+
+install(DIRECTORY include
+ DESTINATION .
+ PATTERN ".svn" EXCLUDE
+ PATTERN "*.cmake" EXCLUDE
+ PATTERN "*.in" EXCLUDE
+ )
+
+# BlocksRuntime - some random cruft that got thrown in at the last minute, ignoring for now.
+# ADD_SUBDIRECTORY( BlocksRuntime )
+ADD_SUBDIRECTORY( lib )
+# Tests are being ignored for until the very basics are working.
+# ADD_SUBDIRECTORY( test )
+
+# Creates a shared lib .so
+ADD_LIBRARY( ${PROJECT_NAME} SHARED ${SRCS})