summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKuba Mracek <mracek@apple.com>2017-07-07 22:40:13 +0000
committerKuba Mracek <mracek@apple.com>2017-07-07 22:40:13 +0000
commit671ef704cfa72856adc7c9a3686a21cb3c1c00ab (patch)
treeafc1d1f1810a04d3532011fd882b018c5bd15738 /CMakeLists.txt
parent0a9913ccddd8ede214f20c45aaaf702203908588 (diff)
Make sure SANITIZER_MIN_OSX_VERSION is defined before using it.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@307448 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 315223358..3195de1e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,7 +80,7 @@ pythonize_bool(COMPILER_RT_DEBUG)
include(config-ix)
-if(APPLE AND SANITIZER_MIN_OSX_VERSION VERSION_LESS "10.9")
+if(APPLE AND SANITIZER_MIN_OSX_VERSION AND SANITIZER_MIN_OSX_VERSION VERSION_LESS "10.9")
# Mac OS X prior to 10.9 had problems with exporting symbols from
# libc++/libc++abi.
set(use_cxxabi_default OFF)