summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2016-10-06 16:45:40 +0000
committerVedant Kumar <vsk@apple.com>2016-10-06 16:45:40 +0000
commit344db1305cce76d0171ef0e45d0cb9c4a7dd95a5 (patch)
tree82ac9e8dbe1720ae0fac8433215f78c2203b1797 /CMakeLists.txt
parent76d9f4a264e496d6b8d52188f496a61a45b609b2 (diff)
[ubsan] Turn on 'Has CXXABI' to enable support for -fsanitize=vptr on Darwin
Differential Revision: https://reviews.llvm.org/D24990 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@283466 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c9baadc1..256d74c4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,8 @@ option(COMPILER_RT_EXTERNALIZE_DEBUGINFO
# COMPILER_RT_DEBUG_PYBOOL is used by lit.common.configured.in.
pythonize_bool(COMPILER_RT_DEBUG)
+include(config-ix)
+
if(APPLE AND SANITIZER_MIN_OSX_VERSION VERSION_LESS "10.9")
# Mac OS X prior to 10.9 had problems with exporting symbols from
# libc++/libc++abi.
@@ -102,8 +104,6 @@ pythonize_bool(SANITIZER_CAN_USE_CXXABI)
# Setup Compiler Flags
#================================
-include(config-ix)
-
if(MSVC)
# Override any existing /W flags with /W4. This is what LLVM does. Failing to
# remove other /W[0-4] flags will result in a warning about overriding a