summaryrefslogtreecommitdiff
path: root/tools/c-index-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/c-index-test/CMakeLists.txt')
-rw-r--r--tools/c-index-test/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/tools/c-index-test/CMakeLists.txt b/tools/c-index-test/CMakeLists.txt
index ad990e010e..c5cb0591c5 100644
--- a/tools/c-index-test/CMakeLists.txt
+++ b/tools/c-index-test/CMakeLists.txt
@@ -56,10 +56,8 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
COMPONENT c-index-test)
if (NOT CMAKE_CONFIGURATION_TYPES) # don't add this for IDE's.
- add_custom_target(install-c-index-test
- DEPENDS c-index-test
- COMMAND "${CMAKE_COMMAND}"
- -DCMAKE_INSTALL_COMPONENT=c-index-test
- -P "${CMAKE_BINARY_DIR}/cmake_install.cmake")
+ add_llvm_install_targets(install-c-index-test
+ DEPENDS c-index-test
+ COMPONENT c-index-test)
endif()
endif()