summaryrefslogtreecommitdiff
path: root/lib/Headers/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Headers/CMakeLists.txt')
-rw-r--r--lib/Headers/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/lib/Headers/CMakeLists.txt b/lib/Headers/CMakeLists.txt
index f81bfa159f..acfd81716a 100644
--- a/lib/Headers/CMakeLists.txt
+++ b/lib/Headers/CMakeLists.txt
@@ -141,9 +141,7 @@ install(
DESTINATION lib${LLVM_LIBDIR_SUFFIX}/clang/${CLANG_VERSION}/include/cuda_wrappers)
if (NOT CMAKE_CONFIGURATION_TYPES) # don't add this for IDE's.
- add_custom_target(install-clang-headers
- DEPENDS clang-headers
- COMMAND "${CMAKE_COMMAND}"
- -DCMAKE_INSTALL_COMPONENT=clang-headers
- -P "${CMAKE_BINARY_DIR}/cmake_install.cmake")
+ add_llvm_install_targets(install-clang-headers
+ DEPENDS clang-headers
+ COMPONENT clang-headers)
endif()