summaryrefslogtreecommitdiff
path: root/examples/PrintFunctionNames/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/PrintFunctionNames/CMakeLists.txt')
-rw-r--r--examples/PrintFunctionNames/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/examples/PrintFunctionNames/CMakeLists.txt b/examples/PrintFunctionNames/CMakeLists.txt
index 331846286b..4954d146e2 100644
--- a/examples/PrintFunctionNames/CMakeLists.txt
+++ b/examples/PrintFunctionNames/CMakeLists.txt
@@ -6,9 +6,12 @@ set( LLVM_LINK_COMPONENTS
# If we don't need RTTI or EH, there's no reason to export anything
# from the plugin.
-if( NOT LLVM_REQUIRES_RTTI )
- if( NOT LLVM_REQUIRES_EH )
- set(LLVM_EXPORTED_SYMBOL_FILE ${CMAKE_CURRENT_SOURCE_DIR}/PrintFunctionNames.exports)
+if( NOT WIN32 ) # Win32 mangles symbols differently, and
+ # PrintFunctionNames.export contains C++ symbols.
+ if( NOT LLVM_REQUIRES_RTTI )
+ if( NOT LLVM_REQUIRES_EH )
+ set(LLVM_EXPORTED_SYMBOL_FILE ${CMAKE_CURRENT_SOURCE_DIR}/PrintFunctionNames.exports)
+ endif()
endif()
endif()