summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorZachary Turner <zturner@google.com>2017-11-10 22:12:04 +0000
committerZachary Turner <zturner@google.com>2017-11-10 22:12:04 +0000
commitb0d0838e7123c5d01147e799b9494c904aef6a09 (patch)
tree94a01c7d9f1b498bc50b1a1723981bb6756eaa63 /test/CMakeLists.txt
parent1d4a6e13515c0954bfbcd4d88b2b6735df80da19 (diff)
Fix for skipped CMake configuration on debuginfo-tests.
This should have been part of the change to debuginfo-tests, but it was left out. This should get the buildbots green. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@317931 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c1ac9e4f0f..e001891384 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -88,6 +88,13 @@ set(CLANG_TEST_PARAMS
clang_site_config=${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg
)
+if (EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/debuginfo-tests/CMakeLists.txt")
+ # This is a hack to keep existing build build infrastructure working while we
+ # can migrate to the new standard workflow of checking out debuginfo-tests into
+ # llvm/projects or using it in a mono-repo
+ add_subdirectory(debuginfo-tests)
+endif()
+
if( NOT CLANG_BUILT_STANDALONE )
list(APPEND CLANG_TEST_DEPS
llvm-config