summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2017-09-22 22:17:10 +0000
committerVedant Kumar <vsk@apple.com>2017-09-22 22:17:10 +0000
commit945869ef7ba9f6a64f4ed7ec218c75b0a8ed7edb (patch)
treef92737b4e9d56fd73ec5b9b96d816e8a0ec14897 /test/CMakeLists.txt
parent764378e424c468a728c86ac122ae4788c3e3a7b3 (diff)
[test] Enable clang-func-mapping as a test dep with the analyzer
clang-func-mapping should not be a test dependency when the static analyzer isn't being built. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@314036 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5fd6b11f9f..c1ac9e4f0f 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -54,12 +54,12 @@ list(APPEND CLANG_TEST_DEPS
clang-rename
clang-refactor
clang-diff
- clang-func-mapping
)
if(CLANG_ENABLE_STATIC_ANALYZER)
list(APPEND CLANG_TEST_DEPS
clang-check
+ clang-func-mapping
)
endif()