summaryrefslogtreecommitdiff
path: root/lib/Serialization/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Prantl <aprantl@apple.com>2015-02-20 19:44:52 +0000
committerAdrian Prantl <aprantl@apple.com>2015-02-20 19:44:52 +0000
commit979ac58e4601af80900fe314810b0c755f8980d8 (patch)
tree37fc7aa3f833e8ee1cb945c80637105cfd1c6757 /lib/Serialization/CMakeLists.txt
parentacdbdefe39a6f67b800e096153083d5ec4318174 (diff)
Wrap clang module files in a Mach-O, ELF, or COFF container.
This is a necessary prerequisite for debugging with modules. The .pcm files become containers that hold the serialized AST which allows us to store debug information in the module file that can be shared by all object files that were built importing the module. rdar://problem/19104245 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@230044 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Serialization/CMakeLists.txt')
-rw-r--r--lib/Serialization/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Serialization/CMakeLists.txt b/lib/Serialization/CMakeLists.txt
index d885db2297..a1a5ad4abe 100644
--- a/lib/Serialization/CMakeLists.txt
+++ b/lib/Serialization/CMakeLists.txt
@@ -1,5 +1,6 @@
set(LLVM_LINK_COMPONENTS
BitReader
+ Object
Support
)