summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-03-07 00:15:18 +0000
committerEric Fiselier <eric@efcs.ca>2017-03-07 00:15:18 +0000
commitfc2d9054c86c9b8acbc98b06f1b9d8aa0e5d40f9 (patch)
tree5c9922177dbdfef1517668aa4293bfdda4ebf6a4 /CMakeLists.txt
parent268a1e6635635d4030b85f9a901d716e471b9b64 (diff)
Define LLVM_ENABLE_WARNINGS when building standalone clang to ensure warnings get enabled
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@297106 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b84888aace..a095d2b865 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,6 +82,7 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
set(LLVM_SHLIB_OUTPUT_INTDIR ${LLVM_LIBRARY_OUTPUT_INTDIR})
endif()
+ option(LLVM_ENABLE_WARNINGS "Enable compiler warnings." ON)
option(LLVM_INSTALL_TOOLCHAIN_ONLY
"Only include toolchain files in the 'install' target." OFF)