summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-10-18 00:50:20 +0000
committerChris Bieneman <beanz@apple.com>2016-10-18 00:50:20 +0000
commitf3d72179865119be6a102db64b0c37fbc81f528c (patch)
tree8a68b2c3eb6fc3ea43ed59a18969d453078becdb /CMakeLists.txt
parente5e0f9d13f290533374e90b61353e1ffcca86560 (diff)
[CMake] Add a few default passthrough variables for bootstrap builds
This just passes through a few missing CMake variables for multi-stage builds. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@284443 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53e5f33246..abab6ce8cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -546,6 +546,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
set(_BOOTSTRAP_DEFAULT_PASSTHROUGH
PACKAGE_VERSION
+ PACKAGE_VENDOR
LLVM_VERSION_MAJOR
LLVM_VERSION_MINOR
LLVM_VERSION_PATCH
@@ -555,7 +556,8 @@ if (CLANG_ENABLE_BOOTSTRAP)
LLVM_VERSION_SUFFIX
LLVM_BINUTILS_INCDIR
CLANG_REPOSITORY_STRING
- CMAKE_MAKE_PROGRAM)
+ CMAKE_MAKE_PROGRAM
+ CMAKE_OSX_ARCHITECTURES)
if(TARGET compiler-rt)
set(RUNTIME_DEP compiler-rt)