summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-12-05 00:15:20 +0000
committerPetr Hosek <phosek@chromium.org>2017-12-05 00:15:20 +0000
commitdafc52370bdd7295ccb89aef9603ea478be358dc (patch)
treec917d79e0734aea531ab04cade43d68503907991 /CMakeLists.txt
parentfd92d11a8a57ad6e20e007c54ccb28ccc4e5f43e (diff)
[CMake] Don't use comma as an alternate separator
Using comma can break in cases when we're passing flags that already use comma as a separator. Fixes PR35504. Differential Revision: https://reviews.llvm.org/D40762 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@319720 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e27a718e41..8848798515 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -655,7 +655,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
foreach(variableName ${variableNames})
if(variableName MATCHES "^BOOTSTRAP_")
string(SUBSTRING ${variableName} 10 -1 varName)
- string(REPLACE ";" "," value "${${variableName}}")
+ string(REPLACE ";" "|" value "${${variableName}}")
list(APPEND PASSTHROUGH_VARIABLES
-D${varName}=${value})
endif()
@@ -671,7 +671,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
if("${${variableName}}" STREQUAL "")
set(value "")
else()
- string(REPLACE ";" "," value "${${variableName}}")
+ string(REPLACE ";" "|" value "${${variableName}}")
endif()
list(APPEND PASSTHROUGH_VARIABLES
-D${variableName}=${value})
@@ -699,7 +699,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
USES_TERMINAL_CONFIGURE 1
USES_TERMINAL_BUILD 1
USES_TERMINAL_INSTALL 1
- LIST_SEPARATOR ,
+ LIST_SEPARATOR |
)
# exclude really-install from main target