summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2017-01-25 13:11:45 +0000
committerMichal Gorny <mgorny@gentoo.org>2017-01-25 13:11:45 +0000
commitc59c9c76caeefa2cba8756cab2e8c5023ecd4cb2 (patch)
tree7c91dd0f45d8b76c7134aa80a78bb08756b6f623 /CMakeLists.txt
parent3157fe19a3c90ea5230599c4fde830d34a5510ab (diff)
[test] Port clang tests to canonicalized booleans
Use the new llvm_canonicalize_cmake_booleans() function to canonicalize booleans for lit tests. Replace the duplicate ENABLE_CLANG* variables used to hold canonicalized values with in-place canonicalization. Use implicit logic in Python code to avoid overrelying on exact 0/1 values. Differential Revision: https://reviews.llvm.org/D28529 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@293052 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 417a907731..4764d5cfc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -364,18 +364,7 @@ option(CLANG_BUILD_TOOLS
"Build the Clang tools. If OFF, just generate build targets." ON)
option(CLANG_ENABLE_ARCMT "Build ARCMT." ON)
-if (CLANG_ENABLE_ARCMT)
- set(ENABLE_CLANG_ARCMT "1")
-else()
- set(ENABLE_CLANG_ARCMT "0")
-endif()
-
option(CLANG_ENABLE_STATIC_ANALYZER "Build static analyzer." ON)
-if (CLANG_ENABLE_STATIC_ANALYZER)
- set(ENABLE_CLANG_STATIC_ANALYZER "1")
-else()
- set(ENABLE_CLANG_STATIC_ANALYZER "0")
-endif()
if (NOT CLANG_ENABLE_STATIC_ANALYZER AND CLANG_ENABLE_ARCMT)
message(FATAL_ERROR "Cannot disable static analyzer while enabling ARCMT")
@@ -415,11 +404,6 @@ add_subdirectory(tools)
add_subdirectory(runtime)
option(CLANG_BUILD_EXAMPLES "Build CLANG example programs by default." OFF)
-if (CLANG_BUILD_EXAMPLES)
- set(ENABLE_CLANG_EXAMPLES "1")
-else()
- set(ENABLE_CLANG_EXAMPLES "0")
-endif()
add_subdirectory(examples)
if(APPLE)