summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Gottesman <mgottesman@apple.com>2016-07-10 01:44:00 +0000
committerMichael Gottesman <mgottesman@apple.com>2016-07-10 01:44:00 +0000
commitaec29e5973c27bcbc3c1cf54295e3778050a73cd (patch)
treeb280c05f6dedd679d669369c49e45a5dab396eb0 /CMakeLists.txt
parent56c01b37d98bd34e56c2d2ed4659ab2be50ac706 (diff)
Add CLANG_BUILD_TOOLS as a clang counterpart for LLVM_BUILD_TOOLS
LLVM_BUILD_TOOLS is a boolean variable that controls whether or not generated targets for llvm tools are built by the "all" target. CLANG_BUILD_TOOLS is an analogous variable for clang targets. This is useful functionality for selectively disabling the building of clang targets by default to speed up builds. In terms of implementation, I just followed the model of LLVM's implementation of this functionality. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@275006 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a37b64aeb..cfcd2212cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -342,6 +342,9 @@ endif()
add_definitions( -D_GNU_SOURCE )
+option(CLANG_BUILD_TOOLS
+ "Build the Clang tools. If OFF, just generate build targets." ON)
+
option(CLANG_ENABLE_ARCMT "Build ARCMT." ON)
if (CLANG_ENABLE_ARCMT)
set(ENABLE_CLANG_ARCMT "1")