summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-06-24 20:21:12 +0000
committerChris Bieneman <beanz@apple.com>2016-06-24 20:21:12 +0000
commit7c599a54a6a9431a44112599fc9166a0e381e932 (patch)
tree10a9c2b5c92bcd2efd3be62a7369c89e81638057 /CMakeLists.txt
parent912e4df3f84136016be5ee6a504ae3587f478426 (diff)
[CMake] Remove CLANG_APPEND_VC_REV option
I added this option in r257827 to try and add compatibility with autoconf. At the time I misunderstood the problem. Our CMake automatically generates the SVN revision information and generates a build action to update it so builds don't need to be re-configured on SCM update (which is a better solution than we had in autoconf). The problem I was actually seeing was isolated cases where SVN revision information isn't available because the repository structures have been removed. This happens in some automated testing systems. This patch allows SVN_REVISION to be overridden if the build configuration could not find the SCM repository structures, and removes the code from my original patch because it is unnecessary. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@273714 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 114d23095e..6a65608954 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,19 +214,6 @@ if(CLANG_REPOSITORY_STRING)
add_definitions(-DCLANG_REPOSITORY_STRING="${CLANG_REPOSITORY_STRING}")
endif()
-option(CLANG_APPEND_VC_REV
- "Append the version control system revision id to clang version spew" OFF)
-if(CLANG_APPEND_VC_REV)
- if(NOT SVN_REVISION)
- # This macro will set SVN_REVISION in the parent scope
- add_version_info_from_vcs(VERSION_VAR)
- endif()
-
- if(SVN_REVISION)
- add_definitions(-DSVN_REVISION="${SVN_REVISION}")
- endif()
-endif()
-
set(CLANG_VENDOR_UTI "org.llvm.clang" CACHE STRING
"Vendor-specific uti.")