summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-09-21 20:43:43 +0000
committerChris Bieneman <beanz@apple.com>2016-09-21 20:43:43 +0000
commit29d34c9a97824b10717654a125810ecb10b90305 (patch)
tree0d7f321f37f287f3d848a7c66611e8daa68d22fc /CMakeLists.txt
parent1db13efe1beedb177f329d6b3945b08b6f460468 (diff)
[CMake] Pass CLANG_VERSION_* variables into later stages
When supporting overriding clang versions we also need to pass those through to the next stage so they remain overridden. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@282109 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7efef3c4a6..12f79df6e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -549,6 +549,9 @@ if (CLANG_ENABLE_BOOTSTRAP)
LLVM_VERSION_MAJOR
LLVM_VERSION_MINOR
LLVM_VERSION_PATCH
+ CLANG_VERSION_MAJOR
+ CLANG_VERSION_MINOR
+ CLANG_VERSION_PATCHLEVEL
LLVM_VERSION_SUFFIX
LLVM_BINUTILS_INCDIR
CLANG_REPOSITORY_STRING