summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-11-23 23:34:13 +0000
committerChris Bieneman <beanz@apple.com>2015-11-23 23:34:13 +0000
commit1ec22fd3823ad237b45a972345e0d9eafceeea6b (patch)
tree6ec31e67805b01c59f7b20e8727575090988a342 /CMakeLists.txt
parentc3a196b7398a8dc3bb832daccf87ed5c261427a3 (diff)
NFC. Fixing my consistently incorrect spelling.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@253937 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bddc25034b..ba7926bd14 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -664,21 +664,21 @@ if (CLANG_ENABLE_BOOTSTRAP)
# Find all variables that start with BOOTSTRAP_ and populate a variable with
# them.
get_cmake_property(variableNames VARIABLES)
- foreach(varaibleName ${variableNames})
- if(varaibleName MATCHES "^BOOTSTRAP_")
- string(SUBSTRING ${varaibleName} 10 -1 varName)
- string(REPLACE ";" "\;" value "${${varaibleName}}")
+ foreach(variableName ${variableNames})
+ if(variableName MATCHES "^BOOTSTRAP_")
+ string(SUBSTRING ${variableName} 10 -1 varName)
+ string(REPLACE ";" "\;" value "${${variableName}}")
list(APPEND PASSTHROUGH_VARIABLES
-D${varName}=${value})
endif()
endforeach()
# Populate the passthrough variables
- foreach(varaibleName ${CLANG_BOOTSTRAP_PASSTHROUGH} ${BOOTSTRAP_DEFAULT_PASSTHROUGH})
- if(${varaibleName})
- string(REPLACE ";" "\;" value ${${varaibleName}})
+ foreach(variableName ${CLANG_BOOTSTRAP_PASSTHROUGH} ${BOOTSTRAP_DEFAULT_PASSTHROUGH})
+ if(${variableName})
+ string(REPLACE ";" "\;" value ${${variableName}})
list(APPEND PASSTHROUGH_VARIABLES
- -D${varaibleName}=${value})
+ -D${variableName}=${value})
endif()
endforeach()